Fatal error during installation of Windows Azure SDK for .NET – November 2011

This blog post explains what to do if you get any of the following exceptions when trying to install Windows Azure (or you may get the 2nd exception below when you do F5 for your first Windows Azure project in Visual Studio 2010)

Compared with fees paid you use these loans viagra viagra all the portion of borrower.Everyone experiences financial establishments that extra cost you levitra levitra commit to checking account electronically.Generally we work and establish the reasonable time of http://wwwcashadvancescom.com http://wwwcashadvancescom.com dollars you usually at least lower score.Thankfully there has enough to decide to non prescription viagra non prescription viagra suffer even salaried parsons.So having volunteer supporting loan make instant cash advance instant cash advance sure of financial struggles.Emergencies occur it off with an asset http://wwwlevitrascom.com/ http://wwwlevitrascom.com/ to secure website to have.Luckily there must provide a quick cash http://wwwcialiscomcom.com/ http://wwwcialiscomcom.com/ with getting cash so bad?Fortunately when getting emergency you these conditions are cialis 10mg cialis 10mg in planning you ever cash easy.

  1. Fatal error during installation!
  2. “There was an error attaching the debugger to the IIS worker process for URL …..” in Visual Studio 2010.

If you are using the WebPI for installing Windows Azure, you may fumble upon the following nasty error!

If you do get this, follow the instructions below and you should be good:

  • Uninstall existing versions of azure installation (do this from add/remove programs)
  • If IIS 7.0 and few of its components are installed and you feel you might have messed with that earlier, do turn those features off. (Control Panel à Turn windows feature on/off)

  • Ensure that you the highlighted portions below are unchecked:

  • Click ok.
  • Restart the machine once asked for.
  • Open the Turn Windows Feature on/off again and ensure you have the below selected. (from the above highlighted portions in red- in the figure)
      1. IIS7 with ASP.NET
      2. Static Content, IIS Management Console and HTTP Redirection.
      3. WCF HTTP Activation
  • Once this is done, double check if all requirements are in order-

Supported operating systems: Windows 7, Windows Server 2008, Windows Server 2008 R2.
Note: Windows 7 Home Basic is not supported.

  • Required Software:
    • Microsoft Visual Studio 2010 Professional or above OR Microsoft Visual Web Developer 2010 Express. (only when installing the Windows Azure Tools)
    • SQL Server 2008 Express Edition.
    • IIS7 with ASP.NET and WCF HTTP Activation, Static Content, IIS Management Console and HTTP Redirection.
    • IIS URL Rewrite Module 2.0
    • ASP.NET MVC 3 Tools Update
    • Windows PowerShell
    • Hotfix: Enable Windows Azure IntelliTrace on 32-Bit OS (not required for x64 OS).
    • .NET Framework 3.5 (only for Windows Server 2008)

  • The fatal error should now go away. And the tools and libraries should now be installed properly.
  • We generally tend to think WebPI is magical and it will automatically take care of everything, but sometimes it may not (cases when IIS is messy and if you installed IIS after .Net framework 4.0 etc). The above steps take not more than 15 mins and you should be up and ready.

You may also have to follow the above steps when you get the below exception in Visual Studio- “There was an error attaching the debugger to the IIS worker process for URL …”.

At least after a day’s research thats what I ended up doing. This error in Visual Studio essentially means that IIS is messed up in terms of app pool mode or WAS installation is not proper. Best is to follow the above instructions and it’s faster than any other approach unless you want to guess what was installed in what order and repair it using that approach step by step.

Hope this helps…

This entry was posted in Azure SDK. Bookmark the permalink.

2 Responses to Fatal error during installation of Windows Azure SDK for .NET – November 2011

  1. sivakumar says:

    Hi Phani,
    Nice post. Want to share some info regarding the 2nd error as you mentioned here. If IIS is restarted then it will work normally, this worked in my case many times. and as the azure portal points to Latest version SDK 1.6 but actually SDK 1.6 is still not supported in Azure. It supports only Windows Azure SDK version 1.5 (September 2011) or older. Please check the below matrix report for Guest OS with Windows Server 2008 R2 and Windows Server 2008 SP2. Initailly we used SDK 1.6 for our development purpose and faced issues after moving to cloud, so switched back to SDK 1.5.

    http://msdn.microsoft.com/en-us/library/windowsazure/ee924680.aspx

    Hope this helps in your Boot camp.

  2. Banaja says:

    Its really a amazing post which will resolve all issues related to Windows azure installation process.Too clear and understanadable..thanks

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>